Improper Input Validation in Metricbeat Leading to Denial of Service
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 7.0.0-alpha2.0.20251217054608-6e42552a23ce, 8.19.10, 9.1.10, 9.2.4
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: none
- Automatable: no
- Technical impact: partial
Summary
Improper Validation of Array Index (CWE-129) exists in Metricbeat can allow an attacker to cause a Denial of Service through Input Data Manipulation (CAPEC-153) via specially crafted, malformed payloads sent to the Graphite server metricset or Zookeeper server metricset. Additionally, Improper Input Validation (CWE-20) exists in the Prometheus helper module that can allow an attacker to cause a Denial of Service through Input Data Manipulation (CAPEC-153) via specially crafted, malformed metric data.
Timeline
- CVE published
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: partial
- Record last updated
Affected versions
- Elastic Metricbeat
From 7.0.0 · through 7.17.29; From 8.0.0 · through 8.19.9; From 9.0.0 · through 9.1.9; From 9.2.0 · through 9.2.3
- github.com/elastic/beatsGo
All versions
- github.com/elastic/beats/v7Go
fixed in 7.0.0-alpha2.0.20251217054608-6e42552a23ce
- github.com/elastic/beats/v7Go
From 8.0.0 · fixed in 8.19.10
- github.com/elastic/beats/v7Go
From 9.0.0 · fixed in 9.1.10
- github.com/elastic/beats/v7Go
From 9.2.0 · fixed in 9.2.4