Skip to main content
← All vulnerabilities
CVE-2025-9714

Stack overflow in libxml2

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.10.0, 2.12.7+dfsg+really2.9.14-0.4ubuntu0.3, 2.9.14+dfsg-1.3ubuntu3.5, 2.9.13+dfsg-1ubuntu0.9, 2.9.10+dfsg-5ubuntu0.20.04.10+esm2, and 3 more
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Uncontrolled recursion in XPath evaluation in libxml2 up to and including version 2.9.14 allows a local attacker to cause a stack overflow via crafted expressions. XPath processing functions `xmlXPathRunEval`, `xmlXPathCtxtCompile`, and `xmlXPathEvalExpr` were resetting recursion depth to zero before making potentially recursive calls. When such functions were called recursively this could allow for uncontrolled recursion and lead to a stack overflow. These functions now preserve recursion depth across recursive calls, allowing recursion depth to be controlled.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • libxml2

    fixed in 2.10.0; fixed in 2.12.7+dfsg+really2.9.14-0.4ubuntu0.3; fixed in 2.9.14+dfsg-1.3ubuntu3.5; fixed in 2.9.13+dfsg-1ubuntu0.9; fixed in 2.9.10+dfsg-5ubuntu0.20.04.10+esm2; fixed in 2.9.4+dfsg1-6.1ubuntu1.9+esm5; fixed in 2.9.3+dfsg1-1ubuntu0.7+esm10; fixed in 2.9.1+dfsg1-3ubuntu4.13+esm9

References 1

gitlab.gnome.org